Skip to content

Uninstall Office 2010 Technical Preview (Mondo)

September 23, 2009

Apparently I’m not the only one who checked out Office 2k10 Technical Preview (Mondo) and was then unable to uninstall it. When trying to remove with Add/Remove Programs, I would just get an error that it was corrupt, and I had to re-install from the CD or file. Re-installation did nothing to fix the problem, but a bit of searching turned up this little gem in a help forum:

To uninstall Office 2010 14.0.4302.1000 if you have an uninstall error message “This product installation has been corrupted”.
The Problem is a missing file in the installation folder of office 2010. Office 2010 has an Setup Controller directory and uses the directory to check the installed components. please check the directory “C:\Program Files\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\Groove.en-us\”. if you have no “Setup.xml” file there please copy the file from the “Groove.en-us” directory of the source files to this directory and test the uninstallation again.

Many thanks to Vikas Narula at http://social.technet.microsoft.com/ for the amazing fix.

About these ads
53 Comments leave one →
  1. Jeff permalink
    November 10, 2009 6:49 pm

    Excellent worked a treat thanks very much!!

  2. K. V. Kesava Rao permalink
    November 14, 2009 11:54 pm

    Excellent tip. I wonder why Microsoft did not take care of this issue.

  3. November 15, 2009 10:03 pm

    holy crap that’s awesome! THANK YOU SO MUCH for posting this fix!

  4. vin permalink
    November 17, 2009 10:57 pm

    please tell how to uninstall… i lost the setup files… now im trying to uninstall… its saying please use ur cd or dvd to uninstall… i deleted the folder but its not removed… once i select the office in programs its starting automatically running setup and opening… i don wan dis 2010… i want to uninstall… please help me..

  5. mingo permalink
    November 19, 2009 3:46 am

    @vin
    Oh my goodness dude he just posted the fix. Follow the directions and it works.

  6. ABR permalink
    November 19, 2009 3:22 pm

    Wonder full……. & Thank You….

  7. November 21, 2009 1:32 pm

    Let me try then i will say you..

  8. Ascel permalink
    November 26, 2009 5:50 am

    Great job. Thank you

  9. Felix permalink
    November 30, 2009 2:40 am

    Thank you so much for that!

  10. Sergio permalink
    December 22, 2009 9:29 pm

    I cannot try this because i deleted all folders and entries bus it still appears as if it’s installed i don’t know what to do can any ine help?

  11. Adi permalink
    January 4, 2010 9:26 am

    EXCELLENT JOB! WORKS WONDERFULLY!!!!

  12. Dan permalink
    January 16, 2010 3:21 pm

    If you still need help email me i got any files you need or whole disc @Sergio

  13. simone permalink
    January 22, 2010 2:00 am

    i founf where it says office14 but cant find the other paths/options

  14. simone permalink
    January 22, 2010 2:13 am

    found it but now cant find groove en us file dont even think have groove came with version i have not listed in programs

  15. xero permalink
    January 27, 2010 8:46 pm

    could you please send me the file “setup.xml”. my email is negativezero@hotmail.co.uk @ dan
    much obliged

  16. xero permalink
    January 27, 2010 8:47 pm

    send me the setup.xml @ negativezero@hotmail.co.uk @Dan

  17. Vimal permalink
    January 27, 2010 9:23 pm

    Initially I downloaded MS off 2010 beta from windows MS site; but i stopped its installation in the middle… Now am not sure whether the system has it installed or not… but when i try to uninstall ofice 2010 with ADD or Remove programs – I get an error msg as “THE LANGUAGE OF THIS INSTALLATION PACKAGE IS NOT SUPPORTED BY YOUR SYSTEM”… Pls pls pls help me out fix this issue…

  18. Bilal permalink
    February 1, 2010 2:50 am

    Setup.xml exits at the specified location. Uninstaller shows the first screen and then “Corrupt Installation” message.

    i even tried to run the original setup, same error message

  19. ikhameur permalink
    February 1, 2010 7:42 pm

    thank you very mush
    direct answer
    no turning
    thanks

  20. sam permalink
    February 6, 2010 12:40 am

    @xero
    can u pls send me the setup.xml file for microsoft office 2010 mondo uninstallation.
    thanks!!

  21. sam permalink
    February 6, 2010 12:42 am

    @Adi
    can u pls send me the setup.xml file for microsoft office 2010 mondo uninstallation.
    thanks!!

  22. Mike permalink
    February 7, 2010 6:32 pm

    Please e-mail me the file m_12monkeys@yahoo.com

    Thanks

  23. Gustavo Schuster permalink
    February 16, 2010 5:10 pm

    Download setup.xml file here: http://tech-buzz.net/wp-content/uploads/Office2010/setup.xml

  24. A L I permalink
    February 27, 2010 4:11 am

    Wonder full.
    Good work. many thanks.

  25. AOmy permalink
    March 1, 2010 5:54 am

    Thanks bro…it really helps me….

  26. March 7, 2010 2:29 pm

    thanks very much for your perfect solution

  27. shark permalink
    March 9, 2010 7:06 pm

    @Vimal
    vimal did you get the information about how to fix youre problem because i have the same problem here:S

  28. Orig permalink
    March 26, 2010 11:13 am

    Wonderful tip!! Thanks so much.

  29. Simon permalink
    March 28, 2010 10:26 am

    Thanks chief;) It was uninstalled successfully!

  30. Maarten permalink
    April 3, 2010 11:05 am

    This is of great help! Thank you!

  31. Maarten permalink
    April 3, 2010 11:15 am

    This was of great help! Thank you!

  32. citro permalink
    April 4, 2010 7:24 pm

    @vimal & @shark
    I have a fix for the error of Language is not supported!!!

    If you copy the content of the installation CD to a folder or just haved unpacked the iso in a folder… do that again, it seems that some installation file is missed or corrupted.

    I did that and worked for me, and I installed without problems.

  33. Shailendra Singh permalink
    April 9, 2010 3:43 pm

    Thanx a million dude !! it really worked . gr8 job

  34. Bill permalink
    April 12, 2010 1:13 pm

    I too Am having an issue installing office 2010. The error message I receives says I must first uninstall the pre-release version. I have un-installed all of the programs associated with office 14, still receive the same message. Any thoughts would be appreciated.

  35. Mike permalink
    April 17, 2010 10:00 am

    I got the setup file and put it in the correct folder. I tried to un-install the program. I got the same error message. I tried to restart my computer, then un-install it. Still nothing. Can someone please help me to get this off my computer? I installed Microsoft office 2007 but the default is stuck on 2010. no matter what I do 2007 won’t stick to default it just tells me its not the right kind of file to open.

  36. April 23, 2010 4:55 am

    Thanks, it worked

  37. April 24, 2010 12:05 pm

    Hey it worked … wow , been messing with this for a while. Thanx a mill

  38. neo permalink
    May 6, 2010 2:02 am

    Thanx… dude
    I was tired.. trying to remove office14….. now this fix helped me
    Thanx buddy….

  39. asim permalink
    May 7, 2010 1:52 am

    yahoooooooooooooooooo

  40. May 10, 2010 2:44 pm

    It worked to perfection. That great, Knowledge is shared not in one persons head. God bless u.

  41. Greg permalink
    May 14, 2010 8:28 am

    Hi

    Where do i get this file from?

  42. sudeep permalink
    May 31, 2010 1:50 pm

    i would like to uninstall this program but it ask me for orginal cd . i have try even from the original cd but it could not how can i uninstall it.

  43. Marc permalink
    June 18, 2010 10:38 am

    @Dan could you please send me the files: marctavenier@gmail.com

  44. Sujit Sen permalink
    June 21, 2010 11:45 am

    xero :send me the setup.xml @ negativezero@hotmail.co.uk @Dan

    can u pls send me the setup.xml file for microsoft office 2010 mondo uninstallation.
    thanks!! to sensujit@gmail.com

  45. Sierra permalink
    June 22, 2010 9:18 am

    I seem to be having the same problems. I have it stuck on my computer. All the websites on here seem to not want to load. Can someone please send me the information that everyone got that worked perfectly for them. I would greatly appreciate it. Please email me @ abarai_uchiha@yahoo.com. Thank you!

  46. June 29, 2010 5:21 am

    Thanks. It worked like a charm

  47. skintownace permalink
    July 3, 2010 8:51 am

    Please could you email me the file to leo_ekn@hotmail.com I have the same problem and cant find the file anywhere and the link doesnt work. Thanks

  48. skintownace permalink
    July 3, 2010 9:01 am

    @skintownace
    Its ok guys thanks but i found the original download and just copied and pasted it over.

  49. aswin permalink
    July 21, 2010 12:19 pm

    thanks its very usefull

  50. Ben permalink
    August 6, 2010 5:02 pm

    If you are trying “C:\Program Files(x86)\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\Groove.en-us\” Like I did it will not work. You need to try “C:\Program Files\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\Groove.en-us\” Like the guy suggests.

  51. Karthik permalink
    September 14, 2010 4:02 am

    Hi

    I had office mondo 2010 & i did the above steps for uninstalling the same.

    But when i tried to install Office 2010 Professional plus it throws the below Setup Errors

    Setup is unable to proceed due to the following error(s):
    Microsoft Office 2010 does not support upgrading from a prerelease version of
    Microsoft Office 2010. you must first uninstall any preprelease versions of
    Microsoft Office 2010 products and associated technologies.
    Correct the issue(s) listed above and re-run setup.

    Please help me out.

    Thanks!!!

    Karthik

  52. blackdaisy permalink
    November 3, 2010 9:18 am

    I had the same problem but i downloaded “regseeker”(google it).then went in “find in registry’ typed the name of the exact file i wanted deleted and got rid of them..worked for me!! even got rid of the stubborn uninstalled AVG.Hope it works for you ..all the best.

  53. February 1, 2011 5:17 pm

    ahhh! finally… tyvm!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: